• Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Tutoriel SteamHourBoost V2
#1
SteamHourBoost V2

Comment l'installer ?

Tout d'abord, il faudra vous munir de la dernière version de Node.Js, coffee-script et pm2 :

Code :
wget --no-check-certificate "https://nodejs.org/dist/latest/node-$(curl -L 'nodejs.org/dist/index.tab' | sed -n '2p' | awk '{ print $1 }')-linux-x64.tar.gz" -O /tmp/nodejs.tar.gz
sudo tar --strip-components 1 -xzvf /tmp/nodejs.tar.gz -C /usr/local
sudo npm -g install npm@latest
sudo npm -g install coffee-script pm2
sudo pm2 install coffeescript

Ensuite, télécharger le script sur votre serveur ou cloner à l'aide de git : 

Code :
# Si vous ne l'avez pas sur votre serveur
# Dans Debian/Ubuntu la commande est 'sudo apt-get install git'
git clone https://github.com/frk1/steamhourboostv2.git

Mettez vous dans le dossier, et installer les fichiers : 

Code :
cd steamhourboost
npm install .

Comment l'utiliser ?

Après l'avoir installer, vous pourrez ajouter des utilisateurs à l'aide de coffee :

Code :
coffee user.coffee

Lorsque vous êtes prêt, lancer le script à l'aide de pm2 : 

Code :
pm2 start boost.coffee

Comment redémarrer le script ?

C'est facile, à l'aide de pm2 :

Code :
pm2 restart all





AfficherCrédit:



AutoShop : Netflix, Spotify, Deezer ...
(En cours de création)
#2
/
Code :
usr/local/bin/node: 1: /usr/local/bin/node: cannot create �X�@@$@@@@@��@@@@ ����H��- �������00@@DDP�td�ۙ������TlTlQ�td/lib64/ld-linux-x86-64.so.2GNU GNU�mԮ�քN�渾�1�c����
                                                                             "ě���
3C

4�(�P�0��@b,���Dh�"�$��HA��!)�/p�c�B�GHD�0P��B�`E���A&0@h�����x� ��"?rI�!"@��@��s/" +��A H Dh
                                                 h�L��(���@P A"����T4 @@1��gH5
� �pG��E^q��Q,D@�@ d�<�&�&��X��Ό�p��N�

$ L� �&C�0�A$��v�C!� &`�b/`Mm���T�:
                                          �C�
�P� �)�T����XΠ��cE<�!���              $!pD�
                                ĊVentes de comptes STEAM / ORIGIN / BATLLE NET / UPLAY�VJ)��zt��U�Qht �2 0/��UJ���°�;��L)`uq@Iq�
� ��5n����p����%���e�
��`DE ��P��
            ��@� � 
                         $���ʣ\A�s�2���B&*"�3
��0�L ��a��]^8
                            Y�a�h� J`A�F:@U9�D
F   �" ��) �@d��ȃ J                   @
�f�"@D��R�
             GB�O:L:cH�"4i&E,1(��IA,w08����$�D"(��@�� ��Q��n})�!d�1P\T���5X�0T�D��(
���E�7�$ � �Pe&�# a�aJ�Krr�D.��+�p�*#
*HyP�d� 

 h@GB�p�D�t
              K&�0�� �
#��AL
�����W�qPP�+x�L,���CT%Иa���� �
�(($,X +bx��`�t$�
                       V$H�b`���D�
                                   ����U!���Bl1� �ab�ѳ�() btAK c\!N�@.��I��D%9s��$Xّ
                    �
                     �M"H�L��Fb���ӡ
�@: Directory nonexistent             �\`�p��@BP�a
/usr/local/bin/node: 1: /usr/local/bin/node: ELF: not found
/usr/local/bin/node: 1: /usr/local/bin/node: F
                                              *���V2�f���՘ļ�: not found
/usr/local/bin/node: 1: /usr/local/bin/node: : not found
/usr/local/bin/node: 1: /usr/local/bin/node: �Ƞ΂1F�: not found
/usr/local/bin/node: 1: /usr/local/bin/node: ��-@�t������%��: not found
/usr/local/bin/node: 16: /usr/local/bin/node:  AA:i 
�DBhP���j~+�\Y�@
��t�f��061��P�jw�IL@T�Y(�DPRgPT@P@ B��p ʁR9/JE�!P1��� �M: not found
/usr/local/bin/node: 17: /usr/local/bin/node: �@�: not found
/usr/local/bin/node: 18: /usr/local/bin/node: Syntax error: word unexpected (expecting ")")
pi@raspberrypi



J'ai cette erreur quand je rentre cet commande : sudo npm -g install npm@latest
T'aurais une idée ? 
  Répondre
#3
Tu es sur quelle version de linux ?

Et pourquoi il y a un lien vers un sujet du forum ? x)
AutoShop : Netflix, Spotify, Deezer ...
(En cours de création)
  Répondre
#4
Je tourne sous raspberry et j'utilise Raspbian
  Répondre
#5
(29-03-2017, 20:54)Vladimour a écrit : Je tourne sous raspberry et j'utilise Raspbian

Je ne connais pas, essaye d'enlever le sudo avant le npm et vérifie que tout ce qui a avant a bien été installé.
Si ce n'est pas le cas, cela signifie que tu ne dois pas posséder wget et/ou curl (cherche un tuto sur comment les installer sur ton système d'exploitation car je le connais pas).
AutoShop : Netflix, Spotify, Deezer ...
(En cours de création)
  Répondre
#6
coffee user.coffee
Ne fonctionne pas
  Répondre
#7
coffee = pour unbuntu si je me trompe pas zyko, si t'es sur linux oublie x) je sais comment faire sur debian 8/9
  Répondre


Atteindre :